Indonesian Back|Track Team
(ask)error upgrade rubygems - Printable Version

+- Indonesian Back|Track Team (https://www.indonesianbacktrack.or.id/forum)
+-- Forum: Penetration Testing Os (https://www.indonesianbacktrack.or.id/forum/forum-170.html)
+--- Forum: Backtrack (https://www.indonesianbacktrack.or.id/forum/forum-171.html)
+---- Forum: BackTrack 5 (https://www.indonesianbacktrack.or.id/forum/forum-74.html)
+----- Forum: Backtrack 5 Tanya Jawab (https://www.indonesianbacktrack.or.id/forum/forum-86.html)
+----- Thread: (ask)error upgrade rubygems (/thread-1804.html)



(ask)error upgrade rubygems - van candlelight - 02-10-2012

kak, ko BT5 ane setiap apt-get upgrade selalu muncul error yg kaya gini :

Code:
[email protected]:~# apt-get upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up rubygems1.8 (1.3.7-2) ...
update-alternatives: error: alternative gem can't be brother: it is a slave of ruby
dpkg: error processing rubygems1.8 (--configure):
subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of rubygems:
rubygems depends on rubygems1.8 (= 1.3.7-2); however:
  Package rubygems1.8 is not configured yet.
dpkg: error processing rubygems (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
rubygems1.8
rubygems
E: Sub-process /usr/bin/dpkg returned an error code (1)

kalo di dpkg --configure -a juga hasilnya

Code:
[email protected]:~# dpkg --configure -a
Setting up rubygems1.8 (1.3.7-2) ...
update-alternatives: error: alternative gem can't be brother: it is a slave of ruby
dpkg: error processing rubygems1.8 (--configure):
subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of rubygems:
rubygems depends on rubygems1.8 (= 1.3.7-2); however:
  Package rubygems1.8 is not configured yet.
dpkg: error processing rubygems (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
rubygems1.8
rubygems

Huh
tolong pencerahannya kakak" semua...


RE: (ask)error upgrade rubygems - iKONspirasi - 02-10-2012

coba apt-get remove rubygems trus install lagi


RE: (ask)error upgrade rubygems - van candlelight - 02-10-2012

(02-10-2012, 11:19 AM)konspirasi Wrote: coba apt-get remove rubygems trus install lagi

sama aja kak, error nya sama ama yg di atas
Angry Huh


RE: (ask)error upgrade rubygems - iKONspirasi - 02-10-2012

coba diupdate rubygems nya:
Code:
gem install rubygems-update
gem update --system



RE: (ask)error upgrade rubygems - van candlelight - 02-12-2012

(02-10-2012, 02:11 PM)konspirasi Wrote: coba diupdate rubygems nya:
Code:
gem install rubygems-update
gem update --system

ada yg error kak

Code:
[email protected]:~# gem update --system
ERROR:  While executing gem ... (RuntimeError)
    gem update --system is disabled on Debian. RubyGems can be updated using the official Debian repositories by aptitude or apt-get.

Angry


RE: (ask)error upgrade rubygems - tokeex - 02-26-2012

masalah ane sama bro ama TS...
Angry selalu muncul pesan error rubygems