(HELP)Metasploit error setelah update
#1
Assalamu'alaykum IBT

Saya mau nanya gimana cara mengatasi error seperti ini setelah update metasploit pake msfupdate
PHP Code:
root@sww:~# msfconsole
[-] ***
[-] *
[-] * 
Metasploit now requires version 0.11 or higher of the 'pg' gem for database support
[-] * There a three ways to accomplish this upgrade:
[-] * 
1. If you run Metasploit with your system rubysimply upgrade the gem:
[-] *    $ 
rvmsudo gem install pg 
[-] * 2. Use the Community Edition web interface to apply a Software Update
[-] * 3. Uninstalldownload the latest version, and reinstall Metasploit
[-] *
[-] ***
[-] 
[-] 
[-] 
Failed to connect to the databasePlease install the postgresql adapter: `gem install activerecord-postgresql-adapter` (RubyGem version errorpg(0.9.0 not ~> 0.11)
) {
"adapter"=>"postgresql""database"=>"msf3""username"=>"msf3""password"=>"eccd8310""host"=>"127.0.0.1""port"=>7175"pool"=>75"timeout"=>5} ["/opt/framework/ruby/lib/ruby/1.9.1/rubygems.rb:751:in `report_activate_error'""/opt/framework/ruby/lib/ruby/1.9.1/rubygems.rb:214:in `activate'""/opt/framework/ruby/lib/ruby/1.9.1/rubygems.rb:1054:in `gem'""/opt/framework/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/postgresql_adapter.rb:7:in `<top (required)>'""/opt/framework/msf3/lib/fastlib.rb:368:in `require'""/opt/framework/msf3/lib/fastlib.rb:368:in `require'""/opt/framework/msf3/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.2/lib/active_support/dependencies.rb:251:in `block in require'""/opt/framework/msf3/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.2/lib/active_support/dependencies.rb:236:in `load_dependency'""/opt/framework/msf3/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.2/lib/active_support/dependencies.rb:251:in `require'""/opt/framework/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:48:in `resolve_hash_connection'""/opt/framework/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:27:in `spec'""/opt/framework/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:127:in `establish_connection'""/opt/framework/msf3/lib/msf/core/db_manager.rb:185:in `connect'""/opt/framework/msf3/lib/msf/ui/console/driver.rb:201:in `initialize'""/opt/framework/msf3/msfconsole:140:in `new'""/opt/framework/msf3/msfconsole:140:in `<main>'"]

--------------------------------------------------------------

       =[ 
metasploit v4.3.0-testing [core:4.3 api:1.0]
+ -- --=[ 
832 exploits 468 auxiliary 141 post
+ -- --=[ 250 payloads 27 encoders 8 nops
       
=[ svn r15135 updated today (2012.04.18)

msf db_status
[-] No database driver installed. Try 'gem install pg'
msf db_driver
[-] Unknown commanddb_driver

ini gambarnya
[Image: Screenshot-2.png]

tolong para backtrackers solved problem saya , saya sudah mengikuti tutorial lainya di forum ini tapi masih muncul eror tersebut Angry Angry Terimakasih Big Grin
Every one Have Superiority that you don't know..


Messages In This Thread
(HELP)Metasploit error setelah update - by wahyuardan - 04-18-2012, 09:19 PM



Users browsing this thread: 1 Guest(s)