apt-get upgrade eror
#1
Code:
[email protected]:~# apt-get upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages have been kept back:
  backtrack-utils beef uniscan w3af
The following packages will be upgraded:
  whatweb
1 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 0B/804kB of archives.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
tar: ./control: time stamp 2012-02-11 12:29:23 is 40912.476021407 s in the future
tar: ./copyright: time stamp 2012-02-11 12:29:23 is 40912.475554518 s in the future
tar: ./preinst: time stamp 2012-02-11 12:29:23 is 40912.475387947 s in the future
tar: ./changelog: time stamp 2012-02-11 12:29:23 is 40912.475230804 s in the future
tar: .: time stamp 2012-02-11 12:29:23 is 40912.475109141 s in the future
(Reading database ... 292474 files and directories currently installed.)
Preparing to replace whatweb 0.4.8-bt0 (using .../whatweb_0.4.8-bt1_all.deb) ...
installing ruby gems for increased functionality
update-alternatives: using /usr/bin/ruby1.8 to provide /usr/bin/ruby (ruby) in manual mode.
ERROR:  http://rubygems.org/ does not appear to be a repository
ERROR:  Could not find a valid gem 'em-resolv-replace' (>= 0) in any repository
ERROR:  http://rubygems.org/ does not appear to be a repository
ERROR:  Could not find a valid gem 'json' (>= 0) in any repository
ERROR:  http://rubygems.org/ does not appear to be a repository
ERROR:  Could not find a valid gem 'bson_ext' (>= 0) in any repository
ERROR:  http://rubygems.org/ does not appear to be a repository
ERROR:  Could not find a valid gem 'mongo' (>= 0) in any repository
WARNING:  RubyGems 1.2+ index not found for:
    http://rubygems.org/

RubyGems will revert to legacy indexes degrading performance.
ERROR:  Could not find a valid gem 'rchardet' (>= 0) in any repository
update-alternatives: using /usr/bin/ruby1.9.2 to provide /usr/bin/ruby (ruby) in manual mode.
update-alternatives: warning: skip creation of /usr/bin/gem because associated file /usr/bin/gem1.9.2 (of link group ruby) doesn't exist.
/var/lib/dpkg/tmp.ci/preinst: line 10: /usr/bin/gem: No such file or directory
/var/lib/dpkg/tmp.ci/preinst: line 11: /usr/bin/gem: No such file or directory
/var/lib/dpkg/tmp.ci/preinst: line 12: /usr/bin/gem: No such file or directory
/var/lib/dpkg/tmp.ci/preinst: line 13: /usr/bin/gem: No such file or directory
/var/lib/dpkg/tmp.ci/preinst: line 14: /usr/bin/gem: No such file or directory
dpkg: error processing /var/cache/apt/archives/whatweb_0.4.8-bt1_all.deb (--unpack):
subprocess new pre-installation script returned error exit status 127
Errors were encountered while processing:
/var/cache/apt/archives/whatweb_0.4.8-bt1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~#

itu kenapa yah om..? bingung masalah erornya

ama ane jga bingung ga bisa instal lampp

pas di tasksel milih lamp server eror
bacaannya gini : tasksel: aptitude failed (100)

ane kotak pke manual jga ga bisa apt-get update trus tasksel jga sama masalahnya.. ada yang bisa ngasih solusi ga?

terima kasih semua.. Big Grin

#2
cb om mulai dulu dari

Code:
apt-get update

baru

Code:
apt-get upgrade

#3
ane edit pake tag code ya, soalnya tag php bikin mata burem wkwkwk

hmm coba install ruby nya dari awal lagi bro, lakuin satu per satu ya:
Code:
apt-get install build-essential git-core curl

Code:
bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/brother/binscripts/rvm-installer)

Code:
echo '[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm"' >> ~/.bashrc

Code:
. ~/.bashrc

Code:
apt-get install build-essential openssl libreadline6 libreadline6-dev curl git-core
zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-0 libsqlite3-dev sqlite3 libxml2-dev
libxslt-dev autoconf libc6-dev ncurses-dev automake libtool bison subversion

#4
beh mantep nih om ikons ,terimakasih om sudah di bantu Smile

#5
Code:
bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/brother/binscripts/rvm-installer)

untuk commant yang ini om mimin syntaxnya eror

PHP Code:
SaKuRRagi@Coolz:~# bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/brother/binscripts/rvm-installer)
bashline 1syntax error near unexpected token `newline'
bash: line 1: 
`<!DOCTYPE html>

bingung abis itu aneh..
Angry

salah di mana yah ??

makasih sebelumnnya yang udah jawab Smile

maav ane pengguna baru bgt[/php]


#6
Sama kayak punya ane om...

coba main dimari om >> http://code.google.com/p/beef/wiki/Using...tBeEFInBT5 siapa tahu bisa solved errornya.

#7
(02-11-2012, 11:21 AM)sakurragi Wrote:
Code:
bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/brother/binscripts/rvm-installer)

untuk commant yang ini om mimin syntaxnya eror

PHP Code:
SaKuRRagi@Coolz:~# bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/brother/binscripts/rvm-installer)
bashline 1syntax error near unexpected token `newline'
bash: line 1: 
`<!DOCTYPE html>

bingung abis itu aneh..
Angry

salah di mana yah ??

makasih sebelumnnya yang udah jawab Smile

maav ane pengguna baru bgt[/php]

hehe itu ga salah kok bro, kan ada tulisan:
Code:
bash: line 1: syntax error near unexpected token `newline'
bash: line 1: `<!DOCTYPE html>'[/php]

itu artinya filenya ga ada atau servernya down jd curl hanya download .html aja bukan rvm-installernya, sorry klo filenya ternyata ga ada Tongue

setelah ane lihat ternyata ada disini skrg:
Code:
https://raw.github.com/wayneeseguin/rvm/brother/binscripts/rvm-installer

jadi berubah dikit aja menjadi seperti ini:
Code:
bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/brother/binscripts/rvm-installer)

silahkan dicoba lagi Smile

#8
masih sama om mimin.. syntaxnya eror ane cari di google jga kga ketemu masalahnnya..

ane bingung emang fungsi gem dan beef itu buat apa yah??

PHP Code:
SaKuRRagi@Coolz:~# bash -s stable < <(curl -s https://raw.github.com/wayneeseguin/rvm/brother/binscripts/rvm-installer)
bashline 1syntax error near unexpected token `newline'
bash: line 1: 
`<!DOCTYPE html>'
[email protected]:~# 

maaf om mimin ane pemula bgt yah.. Smile

(02-11-2012, 11:31 AM)nursalimah Wrote: Sama kayak punya ane om...

coba main dimari om >> http://code.google.com/p/beef/wiki/Using...tBeEFInBT5 siapa tahu bisa solved errornya.


kalo untuk ini sama aja om ga bisa jga... bingung jga

#9
gpp ane juga belajar kok, ga ada namanya pemula ato expert disini Tongue

eh ane salah kopas bro hahaha, yg bener yg ini:
Code:
https://raw.github.com/wayneeseguin/rvm/brother/binscripts/rvm-installer

ganti aja Big Grin

gem itu installer aplikasi berbasis Ruby, klo ga tau ruby googling aja deh, ruby itu semacam bahasa pemrograman OO tingkat tinggi, sodara seangkatannya itu si ular phyton hehe

klo beef beda lagi, beef itu aplikasi untuk Browser Exploitation, googling aja yak Big Grin

#10
wow mantep kk...
nice inpho jadi seneng backtrack 5.. gudang ilmu nice share banget kak...
ane coba dolo om mimin... Big Grin
setelah ane teliti dari ke 3 tersebut sama aja dah om mimin .. apa situsnya lg down??apa yang laen .. jadi pas ane coba hasilnya sama ajah... Sad(





Users browsing this thread: 1 Guest(s)