Thread Closed
[ FIXED ] TP LINK TL-WN821
#1
Assalamualaikmu wr wb..
Para brother ane mau tanya niy, mengenai usb wifi ane gak kebaca di BT 4 R2...

pertama ane coba ikutin artikel ini, ane pikir sama aja kan antara ubuntu sama BT
http://opensource.telkomspeedy.com/wiki/...buntu_9.10

ane dah coba itu tp hasilnya juga nihil, usb wifi TP link ane gak kebaca juga...
mohon pencerahannya...
Smile

#2
cek di lib/firmware l kira-kira ada ini gk ? ar9170.fw

klo gk ada unduh dulu bro

cd /lib/firmware
wget http://www.kernel.org/pub/linux/kernel/p.../ar9170.fw

Daftar device atheros AR9170 chipset yang nembutuhkan drivers update untuk bekerja dengan baik di backtrack 4 :

* Arcadyan - WN7512
* Atheros - 9170
* Atheros - TG121N
* AVM - FRITZ!WLAN USB Stick N
* AMV - FRITZ!WLAN USB Stick N 2.4
* Cace - Airpcap NX
* D-Link - DWA 160A1
* D-Link - DWA 160A2
* IO-Data - WNGDNUS2
* Netgear - WNDA3100
* Netgear - WN111 v2
* Planex - GWUS300
* Sphairon - Homelink 1202
* TP-Link - TL-WN821N v2
* Z-Com - UB81 BG
* Z-Com - UB82 ABG
* Zydas - ZD1221
* Zyxel - NWD271N

----
Update Drivers :

Code:
Download ar9170.fw
wget http://www.kernel.org/pub/linux/kernel/people/mcgrof/firmware/ar9170/ar9170.fw
ar9170-1.fw
wget http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=blob_plain;f=ar9170-1.fw;hb=brother
ar9170-2.fw
wget http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=blob_plain;f=ar9170-2.fw;hb=brother
Download compat-wireless-2.6.32.3.tar.bz2
wget http://www.orbit-lab.org/kernel/compat-wireless-2.6-stable/v2.6.32/compat-wireless-2.6.32.3.tar.bz2
Ke terminal kk

Code:
tar -xf /root/compat-wireless-2.6.32.3.tar.bz2
cd compat-wireless-2.6.32.3
make
make install
make unload

klo ada error "no such file and directory" maka ini obatnya

Code:
ln -s /usr/src/linux /lib/modules/2.6.30.9/build

edit file di bawah ini

Code:
vim /etc/modprobe.d/blacklist

tambahkan blacklist arusb_lnx , kemudian save terus reboot ..semoga berhasil

FOLLOW @DutaLinux
for more question and sharing about security and Opensource only

#3
(04-29-2011, 04:13 AM)zee eichel Wrote: cek di lib/firmware l kira-kira ada ini gk ? ar9170.fw

klo gk ada unduh dulu bro

cd /lib/firmware
wget http://www.kernel.org/pub/linux/kernel/p.../ar9170.fw

Daftar device atheros AR9170 chipset yang nembutuhkan drivers update untuk bekerja dengan baik di backtrack 4 :

* Arcadyan - WN7512
* Atheros - 9170
* Atheros - TG121N
* AVM - FRITZ!WLAN USB Stick N
* AMV - FRITZ!WLAN USB Stick N 2.4
* Cace - Airpcap NX
* D-Link - DWA 160A1
* D-Link - DWA 160A2
* IO-Data - WNGDNUS2
* Netgear - WNDA3100
* Netgear - WN111 v2
* Planex - GWUS300
* Sphairon - Homelink 1202
* TP-Link - TL-WN821N v2
* Z-Com - UB81 BG
* Z-Com - UB82 ABG
* Zydas - ZD1221
* Zyxel - NWD271N

----
Update Drivers :

Code:
Download ar9170.fw
wget http://www.kernel.org/pub/linux/kernel/people/mcgrof/firmware/ar9170/ar9170.fw
ar9170-1.fw
wget http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=blob_plain;f=ar9170-1.fw;hb=brother
ar9170-2.fw
wget http://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=blob_plain;f=ar9170-2.fw;hb=brother
Download compat-wireless-2.6.32.3.tar.bz2
wget http://www.orbit-lab.org/kernel/compat-wireless-2.6-stable/v2.6.32/compat-wireless-2.6.32.3.tar.bz2
Ke terminal kk

Code:
tar -xf /root/compat-wireless-2.6.32.3.tar.bz2
cd compat-wireless-2.6.32.3
make
make install
make unload

klo ada error "no such file and directory" maka ini obatnya

Code:
ln -s /usr/src/linux /lib/modules/2.6.30.9/build

edit file di bawah ini

Code:
vim /etc/modprobe.d/blacklist

tambahkan blacklist arusb_lnx , kemudian save terus reboot ..semoga berhasil

makasih bnyk om zee, dah mau bantu ane..
Pertama ane dah donlot yg ini
[Image: bt1.jpg]

Kedua ane dah donlot compatnya, tapi saat proses make muncul eror
[Image: bt2.jpg]

Terus ane make install jg muncul pesan eror...
ane minta wangsitnya lg om zee....Big Grin

NB:mohon maaf gmbr gak ane spoiler, gak ngerti caranya gimana...Big Grin

#4
btw reupload lagi om gambar a.. ane di sini cuma bisa liat gambar kodok Big Grin

#5
iaa benerin dulu itu gambarnya biar bisa di bantu oms Smile

#6
dah ane benerin tuh om gambarnya....
mhn wangsitnya om...
Smile

#7
owh sorry om ane gk mudeng ente cari yang kernel sesuai ya .. coz itu kernel nah beda .. kernel backtrack R2 2.6.35.8
FOLLOW @DutaLinux
for more question and sharing about security and Opensource only

#8
Maksudnya ane cari compat sama driver buat versi kernel ane om...???

#9
iya bro ....

cek dengan perintah
uname -a
FOLLOW @DutaLinux
for more question and sharing about security and Opensource only

#10
Sudah bisa di thread sebelah Smile
Closed Thread


Thread Closed


Users browsing this thread: 1 Guest(s)