ask? msfconsole error.. setelah update metasploits
#1
codenya
Quote:msfconsole
[-] Failed to connect to the database: could not connect to server: Connection refused
Is the server running on host "localhost" and accepting
TCP/IP connections on port 7337?
could not connect to server: Connection refused
Is the server running on host "localhost" and accepting
TCP/IP connections on port 7337?
{"adapter"=>"postgresql", "database"=>"msf3dev", "username"=>"msf3", "password"=>"ffe74480", "port"=>7337, "host"=>"localhost", "pool"=>256, "timeout"=>5} ["/opt/metasploit/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/postgresql_adapter.rb:1194:in `initialize'", "/opt/metasploit/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/postgresql_adapter.rb:1194:in `new'", "/opt/metasploit/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/postgresql_adapter.rb:1194:in `connect'", "/opt/metasploit/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/postgresql_adapter.rb:329:in `initialize'", "/opt/metasploit/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/postgresql_adapter.rb:28:in `new'", "/opt/metasploit/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/postgresql_adapter.rb:28:in `postgresql_connection'", "/opt/metasploit/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/abstract/connection_pool.rb:277:in `new_connection'", "/opt/metasploit/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/abstract/connection_pool.rb:287:in `checkout_new_connection'", "/opt/metasploit/msf3/lib/msf/core/patches/active_record.rb:59:in `block (2 levels) in checkout'", "/opt/metasploit/ruby/lib/ruby/1.9.1/monitor.rb:201:in `mon_synchronize'", "/opt/metasploit/msf3/lib/msf/core/patches/active_record.rb:54:in `block in checkout'", "/opt/metasploit/msf3/lib/msf/core/patches/active_record.rb:53:in `loop'", "/opt/metasploit/msf3/lib/msf/core/patches/active_record.rb:53:in `checkout'", "/opt/metasploit/msf3/lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/abstract/connection_pool.rb:95:in `connection'", "/opt/metasploit/msf3/lib/msf/core/patches/active_record.rb:22:in `with_connection'", "/opt/metasploit/msf3/lib/msf/core/db.rb:205:in `default_workspace'", "/opt/metasploit/msf3/lib/msf/core/db_manager.rb:212:in `connect'", "/opt/metasploit/msf3/lib/msf/ui/console/driver.rb:195:in `initialize'", "/opt/metasploit/msf3/msfconsole:143:in `new'", "/opt/metasploit/msf3/msfconsole:143:in `<main>'"]
^[[B^[[B^[[B

Unable to handle kernel NULL pointer dereference at virtual address 0xd34db33f
EFLAGS: 00010046
eax: 00000001 ebx: f77c8c00 ecx: 00000000 edx: f77f0001
esi: 803bf014 edi: 8023c755 ebp: 80237f84 esp: 80237f60
ds: 0018 es: 0018 ss: 0018
Process Swapper (Pid: 0, process nr: 0, stackpage=80377000)


Stack: 90909090990909090990909090
90909090990909090990909090
90909090.90909090.90909090
90909090.90909090.90909090
90909090.90909090.09090900
90909090.90909090.09090900
..........................
cccccccccccccccccccccccccc
cccccccccccccccccccccccccc
ccccccccc.................
cccccccccccccccccccccccccc
cccccccccccccccccccccccccc
.................ccccccccc
cccccccccccccccccccccccccc
cccccccccccccccccccccccccc
..........................
ffffffffffffffffffffffffff
ffffffff..................
ffffffffffffffffffffffffff
ffffffff..................
ffffffff..................
ffffffff..................


Code: 00 00 00 00 M3 T4 SP L0 1T FR 4M 3W OR K! V3 R5 I0 N4 00 00 00 00
Aiee, Killing Interrupt handler
Kernel panic: Attempted to kill the idle task!
In swapper task - not syncing



=[ metasploit v4.4.0-release [core:4.4 api:1.0]
+ -- --=[ 911 exploits - 495 auxiliary - 150 post
+ -- --=[ 250 payloads - 28 encoders - 8 nops
=[ svn r15680 updated yesterday (2012.07.24)

msf >

#2
wrong room!!
Searching please,,sudah banyak thread bahas metasploit error!

#3
tidak ada solusi.. apakah ada yg bisa memberikan jawaban yg lebih baik

#4
database bro mati Big Grin. biasanya keseringan mati ndadak Big Grin

Code:
# rm -r /opt/metasploit/postgresql/data/postmaster.pid
# rm -r /opt/metasploit/postgresql/.s.PGSQL.7175
# rm -r /opt/metasploit/postgresql/.s.PGSQL.7175.lock
# /etc/init.d/metasploit-postgres start

#5
(07-26-2012, 07:23 AM)[email protected] Wrote: tidak ada solusi.. apakah ada yg bisa memberikan jawaban yg lebih baik


kernel panic itu,,lihat infonya,,
udah ada yang pernah bahas itu ..

#6
coba cek di terminal
Code:
update-rc.d postgresql enable
update-rd.d metasploit enable

#7
Alangkah baiknya sobat #[email protected] mencari terlebih dahulu di forum ini, bila tidak ada yang berhasil dengan sekian banyaknya postingan di forum ini mengenai metasploit, baru cobalah buat postingan bertanya atau [ASK], saya rasa, belajarlah mandiri dulu, pasti dapat jalan keluarnya.
=========Cyberly================

Indonesian Backtrack Team Regional Aceh

" Walau diam tetap belajar"

Ghaly Site Online

#8
(07-26-2012, 05:51 AM)[email protected] Wrote: ----

GImana bro ? sudah solv ? please confirmed ya
FOLLOW @DutaLinux
for more question and sharing about security and Opensource only

#9
Nambahin om :

Untuk mengaktifkan postgresql dan metasploit

$ service postgresql start && service metasploit start





Users browsing this thread: 1 Guest(s)